ModelPro Installation and Introductory Guide
Overview
This document describes how to install ModelPro prodides an introduction on its use.
Resour ces
Following are resources on the web:
* Information on ModelPrahattp://modelpro.modeldriven.org/
» Information and specifications for SoaMhttp://soaml.org

* ModelPro download siténttp://download.modeldriven.org/modelpro
e Cameo SOA+ suitéhttp://soaplus.cameosuite.com

Following are other resources:
» Eclipse Help (see topic “ModelPro”)
ModelPro Versions

ModelPro comes in multiple versiondodelPro Gold is an all-in-one package that
contains everything needed to run ModelPro (exb&ggicDraw). This package includes
Eclipse, ModelPro, dependent plugins, JRE, JDK,@pttbnally two application servers.

There are two versions of this all-in-one packadede Pro Gold ASandModelPro
Gold. They are identical except thdbdel Pro Gold AS comes bundled with the
Glassfish and JBoss application servers.

ModelPro Gold ASis the recommended way to use ModelPro since dviegytequired
is supplied and configured, and this approach reguhe least user intervention.
ModelPro Gold is recommended if the user already has an apiglicaerver (e.g.,
Glassfish or JBoss) installed on their system.

Although the ModelPro plugin can be installed og axisting Eclipse application,
ModelPro (or its dependent plugins) can potentiedigflict with other installed plugins.
As a result, thélodel Pro Gold or ModelPro Gold AS packages, with a preconfigured
Eclipse, are recommended.

Environment

This document assumes Cameo SOA+ suite is alreatblled.



PREPARING ECLI|PSE
ModelPro Gold and ModelPro Gold AS

Unzipping the File

TheModelPro Gold andModel Pro Gold AS packages both come in a zip file. This file
should be unzipped to a new directory specificatBated for ModelPro (e.g.,
C:\ModelPro). This new directory path must be ghgince the lengths of the file paths
in the zip file are long and can exceed the maxinemgth specified by Windows.

Do not unzip this file onto the Windows desktogloe user's My Documents directory,
since this makes the file path lengths too long.

MAGICDRAW INTEGRATION
All Eclipse installations, whether they are tfledelPro Gold version or a user’s personal
Eclipse, must be integrated with MagicDraw. Usensions of Eclipse should integrate

with MagicDraw before installing the ModelPro plagi

Integrating with MagicDraw

Launch MagicDraw.

In MagicDraw, select Tools->Integrations.

[ MagicDraw UML 16.0
Fie View Layout Diagrams Options BEsslEl Analyze Tearmwork Window Help
DEERAH -H - B E
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Select the Eclipse entry and press the “Integratiefdgrate” button.



E Integrations FXI

‘fou may integrate MagicDraw with these applications.

Inkeqgration Requirements Status
I 1neelil IDEA Iriteli] IDEA 4.0 o later Mot Inkegrated
@ JBuilder JBuilder 5.0, 9.0, ¥, JBuilder 2005, JBuilder 2006 Enterprise Mot Inkegrated

[ & Eclipse & 3.1 platfiorm or later { JBuilder 2007 or later, RAD ... Integrated

oA oA 4,x under Eclipse Mot Integrated
) MNetBeans MetBeans 6.0 or later Mok Integrated
) AndroMDA AndroMDa 3.2 Mak Inkeqrated

Specify the “Eclipse Home Directory” where the sk application is installed. For
ModelPro Gold or ModelPro Gold AS this is the directory where the package was
unzipped.

[ MagicDraw UML X
MaqicDraw UML Integration Taool

Eclipse Home Direckory: E:'I,ModeIPro| ]

MagicCraw LML Home Direckory:| C:Program Files\MagicDraw LML ]

Requirements: Eclipse 3.1 platform ot later { JBuilder 2007 ar later, RAD 7.0 or later, BEA Warkshop 9.2 ar later )

[ Inkegrate ][ Unintegrate H Close ]

Press the “Integrate” button. A message indicatisgccessful integration will be
displayed.

\i) MagicOraw LML integrated into Eclipse successfully,

PROVISIONING WITH MODEL PRO AND ECLIPSE

This section describes how to use Eclipse and tbeéeMPro plugin to provision a JEE
application from a SoaML model.

Launch Eclipse

Create a new, empty folder in Windows to use asvbikspace folder.

Launch Eclipse by clicking on the <install diregtefeclipse.exe file. Specify the
newly created folder for the workspace.



Verify that the MagicDraw drop down menu is avalgain Eclipse.
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Create an Example Project

In order to show the use of ModelPro, a built-imeple project is used. The same
procedures can be used for a user-defined project.

In Eclipse, select File->New->Example. When thealy box appears, select the
ModelPro->SOA-ML to JEE CRR example.

['a New Example

Select a wizard —

provisioning from a SoalML Model to a JEE implementation

Wizards:

#-(= GEF (Graphical Editing Framework ) Plug-ins 2
#- (2 GMF (Graphical Modeling Framework ) Plug-ns
B2 ModelPro
B MM (experimental)
I [= Other
| B SoaML
- ¥ SoaML to EE Calculator 3
[ g-o-L o FE CRR
- SoaML to JEE Solicitation Management Service
L E = SnaMl - latect from Benositor

8]

A new project in Eclipse calle@ent r al Rol eRegi st ry will appear.



s Java - Eclipse Platform
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Expand the SourceModel folder to display the Magasfd mdzip files.

Double click on the CCR->SourceModel->CentralRolgiRey.mdzip file to launch
MagicDraw inside Eclipse.

The UML model will be displayed inside MagicDraw.
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Provision a JEE Application

Provisioning is the generation of code from a modébdelPro takes a SoaML model
and generates a JEE application. The user caratttenustom code to define the
business logic.

This guide continues using tlkent r al Rol eRegi st ry example to demonstrate how
to use the provisioning capabilities. However, aagr-defined SoaML model can be
used as well.

Right click on the file CentralRoleRegistry.zip aselect ModelPro Tools-
>MagicDraw UML to Provisioned Projects.
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A new project name@RRPr ovi der Conrponent will appear in the workspace
containing the newly provisioned JEE application.
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At this point, a JEE application has been provistbfrom the model. Although it
does not yet have custom business logic, it cacob®iled, deployed, and executed
with default behavior.

ADDING BUSINESSLOGIC

The provisioned Eclipse project contains three @@oode directories. One of these
directories, called user.src, contains stub clas$ésh can be filled in with business
logic. The rest of the code is automatically gatest from the model and should not be
modified.

The exampleCent r al Rol eRegi st ry project contains sample business logic code
that simulates a developer adding custom logic.

Expand theCent r al Rol eRegi st ry project and the
CRRPr ovi der Conponent folder inside th&Cent r al Rol eRegi st ry project to
view the sample business logic Java files.
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File Edit Source Refactor Mavigate Search Project  MagicDray
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B[ User.sre
- arg
== modeldriven
= exarmples
== examples
== centralroleregistry
== errinformationmaodel
= entity
ManagedInformation_Impl java
Organization_Irmpl java
Person_Impl java
Principal_Impl.java
= Crrprovisioning

Copy the files from the user.src folderGant r al Rol eRegi stry

/CRRPr ovi der Conponent and paste them into the same directories in the
CRRPr ovi der Conponent project. This simulates a business developer
modifying the provisioned files in user.src.

When asked if the files should be overwritten, priae “Yes to All” button.

& Confirm Overwriting

“p Person_Impl java' exists in the selected destination. Do you want to overwrite?
-

[ ‘fes l [ Yes To Al ] I Mo ] [ Mo To Al ] [ Cancel ]

Click on the CRRProviderComponent project and sétegject->Clean to rebuild the
Eclipse project.
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Press OK in the Clean dialog box.

Clean wil discard all build problems and built states, The projects wil be rebuit

from scratch.
@ Clean &l projects O Clean projects selected below

=

Ok Cancel

Press OK in the Clean dialog box.
This rebuilds the JEE application with the custarmsibess logic.
CONFIGURING THE APPLICATION SERVER

For those users with a local installation of anligpgion server, and who are not using
theModelPro Gold AS package, this section defines how to configuraplication
server for use with Eclipse and the provisioned dgHlication.

The following instructions are specific to a Glasisfv2.1 installation, but can be
followed for any application server.

In Eclipse, select Window->Preferences. When thkd box appears, select Server-
>Runtime Environments. Press the “Add” button.

Select the Glassfish adapter matching the locad<tikh installation.



& New Server Runtime Environment

New Server Runtime Environment

Define a new server runtime environment

Dowrload addiional server adapters

Select the type of runtime environment:
‘t\,fpe fitter text |

2

- GlassFish
£ GlassFish v1 Java EE 5

& GlassFish v3 Prelude
o Saifin v
- 1BV
#-(= JBoss T
- ObjectWeb v
GlassFish v2.1 Java EE 5! Reference implementation and Production ready,

CCreate a new local server

Browse to the local Glassfish installation location

& New Server, Runtime Environment [ =)(:3]
New GlassFish v2.1 Java EE 5 Runtime é

You can use Instaled RE preferences to create a new JRE
JRE:

Application Server Directory: | C:fProgram Fles/glassfish-v2ur2 | l Browse ..

@ Mt = [ Firish l [ Cancel

The new Glassfish JEE runtime should appear itishe



& Preferences EBX

Etype filter text | Server Runtime Environments E=a -
~EMF Compare A add, remove, or edt server runtime ervironments,
- GlassFish Preference : :
& Hep Server runtime environments:
@ InstalUpdate | Mame Type Add..

w Java & GassFish v2.1 Java ... GlassFish v2.1 Ja...
- JavaScript !
#JET Transformation: |
A :
# Model Validation |
& ModelPro !
# Flug-n Developrment |
@ Run/Debug |
=-Server i
Audio |
Launching |
Runtime Erwvironr i
- Service Policies i
# Tasks |
# Team |
L IRNAL D Dhizar ane
<

i
>

@ [ (074 l [ Cancel I

The Eclipse project created for the provisioned dgfication must be associated with
the Glassfish runtime.

In the Package Explorer view, right click on thejpct and select “Properties”. Then
select “Targeted Runtimes”. Ensure the desiredigared runtime is selected.

& Properties for CRRProviderComponent [ (=]:3]

peierien | i T
Resource — i
%! .
Beanlnfo Path [ & GlassFish v2.1 Java EE 5

Builders
Java Build Path
@ Java Code Style
- Java Compier
& Java Editor
Java EE Madule Depen

Javadoc Location Ol show al runtimes

“MagicDraw = T
Project Facets

Project References

Run/Debug Settings

Server

Service Policies

Targeted Rurtimes
® Task Repository If & runtime that you want to select is not displayed or is disabled you may need to uninstall one or
more of the currently instaled project facets,

Task Tags
& Validation Uninstall Facets...
f S | 3 [Restore Defau\tsl I Apply ]
&) [ K ] l Cancel ]

The application servers are displayed in the sanesv in Eclipse, which is one of the
tabs in the lower right hand corner.

In Eclipse, select Window->Show View->Other. Tlrssthect Server->Servers.



|type filter text

= JPa,
= Mhylyn
= Netd]

= PDE
=+ Server

= Team
= Other

= JavaServer Faces e

= Metdj Buddies
= Metdj Debug
= Operational Q¥T

= PCE Runtime

v

Lsze F2 to display the description for a selected view.

[ Ok l [ Cancel

l

Press “OK”, and the Server tab will be display&dmay be empty.

Right click in this empty tab area and select NeSepver.

{2l Problerns | @ Javadoc [[2) Declaration | Bl Console | ik Servers 52 ¢
State Status

Server

Follow the wizard to add the Glassfish server.



& New Server

Define a New Server

Choose the type of server to create

I
Server's host name: | ocahost

Download addiional server adapters
Select the server type:

[type fiter text |

== GlassFish A
<& GassFish v1 Java EE 5
& GlassFish v2.1 JavaEE 5
& GlassFish v3 Prelude
LT Cailfir w1
GlassFish v2.1 Java EE 5: Reference implermentation and Production ready.

3

Server name: | GlassFish v2.1 Java EE 5 at locahost

Server runtime environment; EGLEISSFiSh v2,1JavaEES V! Add

Configurs runtime environments. ..

Cancel

& New Server

New GlassFish v2.1 Java EE 5 Server

Create a new GlassFish v2.1 Java EE 5 server

Domain MNarme: | domaini |
Domain Directory: | . fProgram Files /glassfish-vaur2/domains | l Browse, .. ]
Administrator 1d: | adrmin |

Administrator Password; | adminadrmin |

@ < Back ” Mext = ] [ Finish ] [ Cancel




DEPLOY THE WEB SERVICE

Now that the provisioned JEE application is builtl @dhe application server configured in
Eclipse, the web service can be deployed to aricgtian server.

This section uses Glassfish as an example apjplicagrver.

Open the Servers view, which may contain multigle/ers.

[l Problerns | @ Javadoc | [ Declaration | B Console | 4 Servers 23
Server State Status

% GlassFish ava EE | #= Stopped

B Boss 5.0 at localhost [ Stopped

Drag and drop the CRRProviderComponent project fteerPackage Explorer view
onto the Glassfish server. The project will appeater the server.

B Problerms [ @ Javadoc [ Dedlaration | B Console |44 Servers &3

Server State Status
= €& GlassFish v2.1 Java EE S at localhost e Stopped
(& CRRProviderComponent
B Boss v5.0 at lecahost i Stopped

Right click on the GlassFish v2.1 server and sed¢att.

e
MNew 4
Open F3
Show In Ale+Shift+n ¥
= Copy Cirl+C
¥ Delete Delets
Rename F2
35 Debug Cirl+AlE+D

Cirl+AlE+R

FIE Publish Clrl+Al+P
Clean...

[ Add and Rernove Projects...
Monitoring 4

[l Problerms | @ Javadoc | [& Dec

(GlassFish Enterprise Server 4

Server Properties Alt+Enter
v2.1 Java EE 5 SUI0CSn oo =

(& CRRProviderComponent
f JBoss ¥5 .0 at lbeahost Fa Stopped

The Console view will show that the applicatiomléployed successfully.



=

[£i Problems | @ Javadoc |[2 Declaration | Bl Console 52 4 Servers
<terminated> E\ViodelProGold\edipse'jretbinijavaw exe (Mar o B EE =3 0d
Euildfile: E:%ModelProGoldh workspace' .metadata .plugyinshorg.eclipse. jgt.server .. gener
deploy.jZee.ejh:

[jar] Building jar: E:iModelProGoldiworkspace) .wetadats’ .pluginstorg.eclipse. 3
tools:
deploy:

[exec] Commwand deploy executed successfully.
deploy-—ur l-message:

[echo] Application Deployed at: http://localhost:5080/CRRProviderComponent
BUILD 3IUCCEISFUL
Total time: 32 seconds

ADMINISTER THE WEB SERVICE

This section describes how to use the Glassfishradamsole to view and administer the
web service.

In the Servers view, right click on the Glassfisiver and select GlassFish Enterprise
Server->View Admin Console.

[ew 4
Open F3
Show In Alt+Shift+w >
= Copy Cirl+C
® Delete Delete
Rename F2
% Restart in Debug Cirl+Aalt+D
2 Restart Cirl+AlE+R
Stop Cirl+AlE+5
EL Publish Cirl+8l+P
Clean...
i Add and Remove Projects., .
Wlonitorin 4
[ Problems [ @ Javadoc [[2, Dedlaration | B Console |4 9
(@ GlassFish Update Center
& Register GlassFish Enterprise Server Alt+Enter

[ Get Support for GlassFish Enterprise Server
@ The Aquarium: News From the GlassFish Community

Sy ssud
Synchronized

View Log File

In the login page, enter the username and passwidrd.default values for Glassfish
are “admin” for the username and “adminadmin” fog password.



Sun GlassFish™Enterprise Server v2.1
Administration Console

User Name: |admin |

Password: |oooooo.... |

Click on the “Web Services” link to view the wehngees.

SunGlassfitEenbeseverves

Common Tasks
|1 Registration
E Application Server
v Applications
Enterprise Application
Wigh Spplications
- EJB Modules
Connector Modules
Lifecycle Modules
pplication Client Mod
> .Q. Weh Services
.Q. ManagementishSeryi
i CuerAEbSErVicE

Weh Services

General Registry

Web Services
Wik Services are deployed and undeployed in the Applications (click to open) sres.

Name 4+ | Application + 4 | Type

ManagemerdWehService Wiy WSDL EJB

QueryiebService Wienny WSDL EJB
e

Click on the “View WSDL" link to view the WSDL anthe URL of the service.



